Do. Dez 2nd, 2021

Vor kurzem hab ich mein doch schon älteres Mainboard gegen ein aktuelles Gigabyte Mainboard ausgetauscht. Das neue Board unterstützt Hybrid EFI, hat jedoch noch ein Award Bios, kann aber bereits von Festplatten > 2 TB booten.

Verbindungsprobleme

Egal, ob mit Linux Mint 11, Debian Testing, Linux Mint Debian Edition oder Sabayon, irgendwie verhielt sich die Netzwerkkarte der Marke Realtek RTL8111E chip (10/100/1000 Mbit) mit den – von den Distributionen zur Verfügung gestellten Treibern – komisch.

Unter Sabayon wurde die Netzverbindung zwar hergestellt, sie war jedoch gleich nach dem Systemstart in Gnome nicht verfügbar. Dies äusserte sich zum Beispiel so, dass der Firefox immer erst nach einem Reload der aktuellen Startseite etwas anzeigte. (Sonst gabs ein Server nicht gefunden).

Unter Debian Testing, Linux Mint 11 und auch Linux Mint Debian Edition, war die NIC anfangs „da“ und man konnte auch eine Verbindung herstellen. Kurz danach jedoch, ging die Verbindung in die Knie und funktionierte nur noch – wenn überhaupt – sporadisch.

Lösung des Problemes

  • Man sucht die Website von Realtek auf und ladet die Datei LINUX driver for kernel 2.6.x and 2.4.x (Support x86 and x64)herunter.
  • Diese entpackt man dann in ein Verzeichnis
  • Dann stellt man sicher, dass man die Kernel Sources zum momentan verwendeten Kernel (uname -a bzw. uname  -r gibt Aufschluß über den installierten Kernel) installiert hat. Die Kernel Sources haben in apt, synaptic etc. in meinem Fall z.B. den Namen linux-headers-2.6.38-8. Bei euch kann das natürlich – abhängig vom verwendeten Kernel – abweichen!
  • Danach öffnet man eine Konsole als root, oder greift auf sudo zurück und wechselt in das Verzeichnis, in das man die heruntergeladene Datei entpackt hat. Dort sollte es dann die Dateien autorun.sh,  log.txt,  Makefile,  README und den Ordner  src geben
  • Die Installation startet man (als root!) durch Eingabe von ./autorun.sh

Bei mir hat das Installationsscript problemlos funktioniert und das neue Modul (den Nic-Treiber) installiert.

Eine Recherche im Internet bringt übrigens zu Tage, dass es offenbar schon länger Probleme mit dieser NIC bzw. dem Standardmodul gibt…

 

Von Daniel

5 Gedanken zu „Gigabyte 970A UD3 AM3 – Netzwerkprobleme“
  1. Tipp für dich:

    Pinne den Kernel fest, ansonsten hast du das Spielchen bei jedem Kernelupdate.
    Wenn du irgendwann mal ein Update installierst, weißt du wenigstens was auch dich zukommt. Hatte das am Montag erst mit einem OVH Server bei dem die Intel Netzwerkkarte nicht läuft mit dem e1000e Treiber. Und im Rescuemode die Treiber für einen anderen Kernel installieren ist rumbiegerei gewesen.
    Daher hab ich den Kernel gleich fest gepinnt und wenn ich ein Update installiere, weiß ich, das ich das Kernelmodul gleich nachkompilieren muss.

    So long
    Lord_Pinhead

    1. Hi,

      ersteinmal danke für die Lösung, ich hatte schon an einen Hardwaredefekt geglaubt bei meinem Board, nun funktioniert es. Nur eine Frage zu der Kernelupdate-Problematik: Wie ist das gemeint mit „Kernel festpinnen“? Inwieweit äußert sich ein Kernelupdate? (linux-headers-…-amd64) im Updatemanager?

      Grüße

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

* Zustimmung zur Datenspeicherung lt. DSGVO

*

Ich bin damit einverstanden

Zur Verbesserung des Service werden anonymisierte Nutzerdaten mittels Google Analytics verarbeitet. Falls Sie das nicht wünschen - > Hier klicken um dich auszutragen.