Di. Jan 18th, 2022

Fliegen unter „Linux“

Auch das ist möglich. Wenn auch mit ein paar kleineren Hürden, sofern man zum Beispiel Debian Lenny einsetzt.

Die Installationsroutine verursacht gleich nach Aufruf das Problem, dass „libopenal.so.0“ nicht gefunden wird. Selbst wenn man das notwendige Library nachinstalliert, das unter Debian Lenny „libopenal.so.1“ heißt, bleibt X-Plane hartnäckig und verweigert die Installation.

Lösung

Ich habe über die Linuxkonsole und den Befehl „ln“,  einen Link von libopenal.so.1 auf libopenal.so.0 erstellt:

  • Wechseln in das Verzeichnis /usr/lib
  • Sicherstellen, dass libopenal.so.1 auch wirklich dort zu finden ist (ansonsten per apt-get installieren)
  • Eingabe von: ln libopenal.so.1 libopenal.so.0
  • gefolgt von RETURN

Durch oben erwähnte Aktion gibt es nun beide „Dateien“ im Verzeichnis /usr/lib. Nur, dass libopenal.so.0 eigentlich auf libopenal.so.1 verweist. Die ganze Aktion sollte keine Probleme verursachen, da libopenal.so.0 unter Debian Lenny einfach von libopenal.so.1 abgelöst wurde.

Jedenfalls sollte nun die X-Plane 9 Installation klappen.

Guten Flug! 😉

Von Daniel

2 Gedanken zu „X-Plane 9 unter Debian Lenny (libopenal.so.0 Problem)“
  1. Auf diese Idee bin ich selbst auch schon gekommen. Trotzdem erhalte ich nach dem Start folgende Fehlermeldung:

    ./X-Plane-806-i586: symbol lookup error: ./X-Plane-806-i586: undefined symbol: alutInit

    Also definitiv ein Problem mit libopenal 🙁

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

* Zustimmung zur Datenspeicherung lt. DSGVO

*

Ich bin damit einverstanden

Zur Verbesserung des Service werden anonymisierte Nutzerdaten mittels Google Analytics verarbeitet. Falls Sie das nicht wünschen - > Hier klicken um dich auszutragen.